Germany | Finland | Saint Petersburg | Drive

Скользящая средняя по объёму

4.7/5 оценка (19 голосов)
  • Версия: 2.1
  • Требования: Quik 8.5
  • Размер: 260.20 KB
  • Просм: 6385
  • Добавлено: 07.07.14
  • Скачано: 1860
  • Изменено: 15.05.20

Индикатор объёма, усредненного скользящей средней. Типы встроенных скользящих средних:

  1. sma
  2. ema
  3. wma
  4. dema
  5. tema
  6. jma
  7. hma
  8. stdev
  9. trima

Индикатор корректно обрабатывает свечи графика, в которые торговля инструментом не велась и соответственно объём равен нулю. Также верно работает в случае наличия на диаграмме индикаторов, сдвинутых влево или вправо.

Архив содержит 2 версии - демонстрационную и полную. Демонстрационная версия работает на интервалах от 1 до 4 минут.

 УСТАНОВКА

  1. В папке терминала необходимо создать папку Luaindicators (если её ещё там нет) и положить туда файл VolumeAverage.lua (или VolumeAverage_full.lua, если вам известен пароль от полной версии)
  2. Библиотеку bot4sale64.dll поместите в папку терминала quik.
  3. Добавляйте индикатор на график обычным способом.

Получить пароль от полной версии можно исполнив посильный вклад на эту банковскую карту или электронный кошелёк

 

BTC: 32qFMk7BcvTF5weiEF9sbnNV1N1SjNiioc
ETH: 0x5ae5d32f266f3eac8c3e9809ea906d9c0d149bfe
Руб: 410012694478342

 

 

 

 

 

 

 

 

Размер пожертвования определяйте сами. Ответить на уточняющие вопросы "сколько" я не смогу. Сообщите мне почтой сумму и в ответ придет пароль. И да, карта действительна. 

Разделы

  • Индикатор
  • Комментарии   

    # Nordon 01.04.2018 08:01
    Здравствуйте, Михаил!

    Добавьте пожалуйста в формулу исключения нулевых значений
    # admin 07.04.2018 14:36
    Держите )
    # Nordon 08.04.2018 07:53
    Михаил, этот индикатор можно применять не только к объемы, а и к любым другим индикаторам?
    # admin 08.04.2018 08:02
    Нет, только к объемам.

    Индикатор, который строит скользящую среднюю от другого индикатора, в принципе сделать можно и с некоторыми оговорками его даже можно будет использовать. Но это отдельная история ...
    # Nordon 08.04.2018 09:25
    Придется тогда сделать пожертвования, а то надоело каждый раз при запуске quik ждать когда пройдут сообщения об ошибке деления на ноль )))
    # admin 08.04.2018 11:32
    Что значит "придется"?

    Пожертвования надо делать с радостью и улыбкой, легко и без сожалений :lol:

    Пароль вам ушел почтой
    # Nordon 08.04.2018 12:17
    Большое спасибо )))
    # Solo 12.03.2019 19:04
    Большое спасибо автору!)
    # Жмот 23.04.2019 16:36
    Брателосы, а "посильный вклад" это примерно сколько? :oops: Уважаемый автор, карта еще актуальна?
    # admin 23.04.2019 17:58
    Да, карта актуальна.
    # Comp_555 30.03.2020 05:54
    Доброго времени суток, хотел бы внести пожертвование, на какую почту нужно отписаться?
    # admin 30.03.2020 06:04
    Здравствуйте

    Почта
    # gvm 18.05.2020 12:51
    Михаил, спасибо за активацию профиля!
    У меня версия quik 8.4.1.6, соответственно версия 2.1 индикатора не поддерживается. Есть ли возможность скачать предыдущую версию индикатора?
    # admin 18.05.2020 13:17
    Здравствуйте

    Более правильным вариантом будет установка последней версии терминала с сайта производителя. Вы избавитесь не только от этой проблемы, но еще и от массы иных
    # gvm 18.05.2020 18:18
    обновил Quik до версии 5.2.1.1. При запуске вышло сообщение, что язык lua теперь версии 5.3 и не полностью совместим с версией 5.1. Теперь не работает ИНДИКАТОР ОБЪЁМОВ С РАЗДЕЛЕНИЕМ НА ПОКУПКИ И ПРОДАЖИ + CUMULATIVE DELTA и привод Cscalp (в обоих случаях ошибки запуска скриптов lua) . Индикатор "СКОЛЬЗЯЩАЯ СРЕДНЯЯ ПО ОБЪЁМУ" тоже установить не смог - Quik выводит сообщение "Syntax error" и по-прежнему "*ошибка установки индикатора*" при попытке выбрать индикатор на графике. Пока решил сделать откат к предыдущей версии Quik ( 8.4.1.6)
    # admin 18.05.2020 18:37
    Ну что тут поделать..

    Невозможно все скрипты и индикаторы одновременно пересобрать под новую версию языка. Через некоторое время все будет под новую версию терминала.

    Касаемо "*ошибка установки индикатора*" - вы используете уже имеющуюся у вас на компьютере библиотеку bot4sale64.dll старой версии, которая работает с терминалом 8.4, но не работает с 8.5

    Для работы с терминалом 8.5 (изменился встроенный язык) нужна новая версия этой библиотеки, она находится в скачанном вами архиве.

    Недостаточно прав для комментирования